# CVE-2026-85014: undici vulnerable to Denial of Service via WebSocketStream unclean close

> An untrusted server can crash a Node.js application using undici's WebSocketStream by abruptly closing the TCP connection, causing an unhandled rejection.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-BJ62373, CLEANSTART-2026-BZ98480, CLEANSTART-2026-CA85404, DEBIAN-CVE-2026-85014, ECHO-a7c6-1ae0-8ec1, GHSA-rx4f-c7p8-82vq, MINI-4gmm-273v-699h, MINI-596h-qmx5-hghf, MINI-5cmm-p8fj-6vp5, MINI-767c-x9xj-pm4w, MINI-7cwc-jr88-jc5h, MINI-924j-7m4v-qhg4, MINI-9q4c-42gw-p6j3, MINI-c723-628f-8pgw, MINI-c7w3-rw3r-q6x3, MINI-cr3j-xg7q-gvqx, MINI-fx57-fqvx-6r69, MINI-gmw5-rqm9-9jr8, MINI-h8rx-fgw6-x6wh, MINI-jpxh-36fr-4fpx, MINI-q4wj-gppv-qqrq, MINI-qwfh-v54f-vrqq, ROOT-APP-NPM-CVE-2026-85014, UBUNTU-CVE-2026-85014

## What is CVE-2026-85014?

CVE-2026-85014 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici's experimental WebSocketStream client crashes the whole Node.js process when a remote peer closes the TCP connection without a WebSocket close handshake. On an unclean close the internal socket-close handler calls abort on the writable stream unconditionally and discards the returned promise, but per the WHATWG Streams standard aborting a locked writable returns a promise that rejects with a TypeError. Because the application holds a writer on that writable, which is the only way to write, the rejection is never observed and Node's default unhandled-rejection behavior terminates the process. An untrusted server can therefore crash a client with a single abrupt disconnect, with no authentication and no application mistake. This affects undici versions from 7.0.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-85014?

4 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 7.0.0 | 7.29.1 |
| `undici` | npm | From 8.0.0 | 8.10.2 |
| `undici` | npm | From 8.0.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-85014?

Upgrade undici to a fixed version for your release line: 7.29.1 or 8.10.2.

## Is CVE-2026-85014 being exploited?

There is no known exploitation of CVE-2026-85014 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85014 and fix it if it is affected.

What it is: CVE-2026-85014 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85014 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 7.0.0; fixed in 7.29.1
- undici (npm): affected from 8.0.0; fixed in 8.10.2
- undici (npm): affected from 8.0.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85014/ (Markdown: https://insights.sbomify.com/CVE-2026-85014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85014
- OSV: https://osv.dev/vulnerability/CVE-2026-85014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85014/
Summaries are generated and may contain mistakes; the official description above is the record.
