CVE-2026-85017 Unlimited Elements For Elementor < 2.0.20 - Subscriber+ PHP Object Injection
Authenticated subscribers can inject arbitrary PHP objects via an unprotected AJAX action, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-85017?
CVE-2026-85017 is a high-severity unsafe deserialization vulnerability in Unknown Unlimited Elements For Elementor, published on 20 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Unlimited Elements For Elementor WordPress plugin before 2.0.20 does not perform a capability check on an AJAX action and deserializes attacker-controlled stored data through it, which makes it possible for authenticated attackers with subscriber-level access to inject arbitrary PHP objects. A partial fix in the 2.0.18 to 2.0.19 releases raised the privilege required to reach the vulnerable action to editor-level, and the issue was fully resolved in 2.0.20.
Weakness: CWE-502
Which versions are affected by CVE-2026-85017?
How do I fix CVE-2026-85017?
No fix has been published for CVE-2026-85017 yet. Limit exposure of the affected software until one is available.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-85017 being exploited?
There is no known exploitation of CVE-2026-85017 in the wild and no public exploit code.
Sources
Also known as GHSA-3wpx-h7q2-mv8g.