{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-85017 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-85017 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85017 is a high-severity unsafe deserialization vulnerability in Unknown Unlimited Elements For Elementor, published on 20 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-85017 and fix it if it is affected.\n\nWhat it is: CVE-2026-85017 is a high-severity unsafe deserialization vulnerability in Unknown Unlimited Elements For Elementor, published on 20 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-85017 in the wild and no public exploit code.\n\nAffected product: Unknown Unlimited Elements For Elementor. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85017/ (Markdown: https://insights.sbomify.com/CVE-2026-85017/index.md)","id":"CVE-2026-85017","markdown":"https://insights.sbomify.com/CVE-2026-85017/index.md","name":"CVE-2026-85017","record":{"aliases":["GHSA-3wpx-h7q2-mv8g"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can inject arbitrary PHP objects via an unprotected AJAX action, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"The Unlimited Elements For Elementor WordPress plugin before 2.0.20 does not perform a capability check on an AJAX action and deserializes attacker-controlled stored data through it, which makes it possible for authenticated attackers with subscriber-level access to inject arbitrary PHP objects. A partial fix in the 2.0.18 to 2.0.19 releases raised the privilege required to reach the vulnerable action to editor-level, and the issue was fully resolved in 2.0.20.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Unlimited Elements For Elementor \u003c 2.0.20 - Subscriber+ PHP Object Injection","id":"CVE-2026-85017","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"langgenius dify Splash Layout splash.tsx router.replace cross site scripting","id":"CVE-2026-85021"},"packages":[],"prev":{"headline":"Unlimited Elements For Elementor \u003c 2.0.21 - Contributor+ Stored XSS via Icon Library Parameter","id":"CVE-2026-85016"},"products":["Unlimited Elements For Elementor"],"published":"2026-09-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-20","vendors":["Unknown"]},"summary":"Authenticated subscribers can inject arbitrary PHP objects via an unprotected AJAX action, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-85017/"}