CVE-2026-85024 undici vulnerable to Denial of Service via unhandled error in WebSocket permessage-deflate decompression
Remote attackers can crash Node.js applications using undici by sending malformed compressed WebSocket payloads that trigger unhandled errors.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-85024?
CVE-2026-85024 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
undici bundles a WebSocket client whose permessage-deflate size-limit cleanup removes all listeners from the internal zlib inflate stream, including its error listener, while that stream can still emit. When a remote peer sends a compressed payload that crosses the built-in 128 MiB decompressed-payload limit and then contains a malformed DEFLATE byte, the inflate stream emits a data error with no listener attached, which Node.js treats as a fatal unhandled error and terminates the entire process. Exploitation is remote and unauthenticated, requires no application mistake, and is asymmetric, since roughly 130 KB on the wire expands past the limit and crashes the process, and reconnecting can repeat the crash. This affects undici versions from 6.25.0 up to 6.28.1, from 7.28.0 up to 7.29.1, and from 8.1.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.
Weakness: CWE-248
Which versions are affected by CVE-2026-85024?
6 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 6.25.0 | 6.28.1 |
undici npm | From 6.25.0 | 6.28.1 |
undici npm | From 7.28.0 | 7.29.1 |
undici npm | From 7.28.0 | 7.29.1 |
undici npm | From 8.1.0 | 8.10.2 |
undici npm | From 8.1.0 | 8.10.2 |
Products include Nodejs Undici.
How do I fix CVE-2026-85024?
Upgrade undici to a fixed version for your release line: 6.28.1, 7.29.1 or 8.10.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-85024 being exploited?
There is no known exploitation of CVE-2026-85024 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as CLEANSTART-2026-DX01357, CLEANSTART-2026-TX86596, CLEANSTART-2026-VA58773, CLEANSTART-2026-VB20350, CLEANSTART-2026-WR14423, CLSA-2026-1790673449 and 25 more.