# CVE-2026-85024: undici vulnerable to Denial of Service via unhandled error in WebSocket permessage-deflate decompression

> Remote attackers can crash Node.js applications using undici by sending malformed compressed WebSocket payloads that trigger unhandled errors.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-DX01357, CLEANSTART-2026-TX86596, CLEANSTART-2026-VA58773, CLEANSTART-2026-VB20350, CLEANSTART-2026-WR14423, CLSA-2026-1790673449, CLSA-2026-1790676913, CLSA-2026-1792867307, DEBIAN-CVE-2026-85024, ECHO-e0e5-842a-a10f, GHSA-3wwx-pv8p-q78v, MINI-22rf-69pf-924r, MINI-25p9-qpmw-5vc3, MINI-4qhr-4575-x2x7, MINI-5xg2-cw3h-94mp, MINI-676m-cwmh-xfq6, MINI-752j-7jjq-5hgx, MINI-823m-w68h-jwpf, MINI-86f3-pmxh-8hx2, MINI-8x8h-3ggg-h893, MINI-jj73-4x2j-73qf, MINI-mmmx-86r5-8988, MINI-pf5g-63vm-rjpp, MINI-qfq5-4537-j374, MINI-rfhj-xf3c-r7fh, MINI-rm37-3xq7-gwr5, MINI-vvf9-j4j5-3jrj, MINI-w2ww-xmpc-g6fr, MINI-x5cq-38h8-g4jw, ROOT-APP-NPM-CVE-2026-85024, UBUNTU-CVE-2026-85024

## What is CVE-2026-85024?

CVE-2026-85024 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici bundles a WebSocket client whose permessage-deflate size-limit cleanup removes all listeners from the internal zlib inflate stream, including its error listener, while that stream can still emit. When a remote peer sends a compressed payload that crosses the built-in 128 MiB decompressed-payload limit and then contains a malformed DEFLATE byte, the inflate stream emits a data error with no listener attached, which Node.js treats as a fatal unhandled error and terminates the entire process. Exploitation is remote and unauthenticated, requires no application mistake, and is asymmetric, since roughly 130 KB on the wire expands past the limit and crashes the process, and reconnecting can repeat the crash. This affects undici versions from 6.25.0 up to 6.28.1, from 7.28.0 up to 7.29.1, and from 8.1.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-85024?

6 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 6.25.0 | 6.28.1 |
| `undici` | npm | From 6.25.0 | 6.28.1 |
| `undici` | npm | From 7.28.0 | 7.29.1 |
| `undici` | npm | From 7.28.0 | 7.29.1 |
| `undici` | npm | From 8.1.0 | 8.10.2 |
| `undici` | npm | From 8.1.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-85024?

Upgrade undici to a fixed version for your release line: 6.28.1, 7.29.1 or 8.10.2.

## Is CVE-2026-85024 being exploited?

There is no known exploitation of CVE-2026-85024 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85024 and fix it if it is affected.

What it is: CVE-2026-85024 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85024 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 6.25.0; fixed in 6.28.1
- undici (npm): affected from 6.25.0; fixed in 6.28.1
- undici (npm): affected from 7.28.0; fixed in 7.29.1
- undici (npm): affected from 7.28.0; fixed in 7.29.1
- undici (npm): affected from 8.1.0; fixed in 8.10.2
- undici (npm): affected from 8.1.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85024/ (Markdown: https://insights.sbomify.com/CVE-2026-85024/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85024
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85024
- OSV: https://osv.dev/vulnerability/CVE-2026-85024

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85024/
Summaries are generated and may contain mistakes; the official description above is the record.
