# CVE-2026-85028: Creation of Temporary File in Directory with Insecure Permissions in AWS FPGA Development Kit

> Local attackers can execute arbitrary code with root privileges by exploiting insecure temporary file handling during installation.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Sep 2026
- **Updated:** 3 Sep 2026
- **Also known as:** GHSA-4qmw-8r9m-c656, GHSA-g4hc-wrmm-2x74

## What is CVE-2026-85028?

CVE-2026-85028 is a high-severity vulnerability in aws-fpga, published on 3 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Creation of a temporary file in a directory with insecure permissions in the FPGA management tool installation component in AWS FPGA Development Kit (aws-fpga) before 2.3.4 might allow local users to execute arbitrary code with root privileges via crafted shell content placed at a predictable path in a world-writable temporary directory, which the installation step reads after elevating its own privileges.

To remediate this issue, users should upgrade to version 2.3.4.

Weakness: CWE-379 (Creation of Temporary File in Directory with Insecure Permissions)

## Which versions are affected by CVE-2026-85028?


## How do I fix CVE-2026-85028?

No fix has been published for CVE-2026-85028 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85028 being exploited?

There is no known exploitation of CVE-2026-85028 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85028 and fix it if it is affected.

What it is: CVE-2026-85028 is a high-severity vulnerability in aws-fpga, published on 3 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85028 in the wild and no public exploit code.

Affected product: aws-fpga. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85028/ (Markdown: https://insights.sbomify.com/CVE-2026-85028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85028
- OSV: https://osv.dev/vulnerability/CVE-2026-85028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85028/
Summaries are generated and may contain mistakes; the official description above is the record.
