# CVE-2026-85055: Twenty: Field-level read bypass

> Attackers can bypass field-level read restrictions in Twenty CRM by using filter predicates to infer denied field values via boolean oracles.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-v93q-4jcx-7p9m

## What is CVE-2026-85055?

CVE-2026-85055 is a high-severity missing authorization vulnerability in twentyhq twenty, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Twenty is an open-source CRM (customer relationship management) platform. Prior to 2.22.0, field-level read permission is enforced on selected output fields but not on GraphQL or REST filter predicates. A workspace member or API key with permission to read an object but not a particular field can reference that denied field in direct filters, relation filters, or persisted view filters. The resulting totalCount and row presence reveal whether guesses match the real column, forming a boolean/count oracle that can reconstruct denied field values for records exposed by the principal's row-level policy. This issue is fixed in version 2.22.0.

Weakness: CWE-285 (Improper Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-85055?


## How do I fix CVE-2026-85055?

No fix has been published for CVE-2026-85055 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85055 being exploited?

There is no known exploitation of CVE-2026-85055 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85055 and fix it if it is affected.

What it is: CVE-2026-85055 is a high-severity missing authorization vulnerability in twentyhq twenty, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85055 in the wild and no public exploit code.

Affected product: twentyhq twenty. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85055/ (Markdown: https://insights.sbomify.com/CVE-2026-85055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85055
- OSV: https://osv.dev/vulnerability/CVE-2026-85055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85055/
Summaries are generated and may contain mistakes; the official description above is the record.
