# CVE-2026-85058: Moquette: Missing Authorization in io.moquette:moquette-broker

> Remote attackers can inject messages into restricted topics via Last Will features when anonymous access is enabled, bypassing write permissions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-9jjc-fw8x-fmwx

## What is CVE-2026-85058?

CVE-2026-85058 is a high-severity missing authorization vulnerability in moquette-io moquette, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Moquette is a lightweight Java MQTT broker. Prior to 0.18.1, PostOffice.publishWill publishes a client-controlled Last Will message through publish2Subscribers without invoking the authorizator.canWrite check used by normal PUBLISH paths. When anonymous access is enabled and topic ACLs restrict writes, a remote client can set an ACL-protected topic as the Last Will Topic during CONNECT and perform an abnormal client disconnect, causing the broker to inject attacker-controlled messages into a topic for which the client lacks write permission. This issue is fixed in version 0.18.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-85058?

2 open source packages ship an affected version, including io.moquette:moquette-broker.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.moquette:moquette-broker` | Maven | All versions | 0.18.1 |
| `io.moquette:moquette-broker` | Maven | All versions | 0.18.1 |

## How do I fix CVE-2026-85058?

Upgrade io.moquette:moquette-broker to 0.18.1 or later.

## Is CVE-2026-85058 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85058 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85058 and fix it if it is affected.

What it is: CVE-2026-85058 is a high-severity missing authorization vulnerability in moquette-io moquette, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85058 exists.

Affected packages and fixed versions:
- io.moquette:moquette-broker (Maven): affected all versions; fixed in 0.18.1
- io.moquette:moquette-broker (Maven): affected all versions; fixed in 0.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85058/ (Markdown: https://insights.sbomify.com/CVE-2026-85058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85058
- OSV: https://osv.dev/vulnerability/CVE-2026-85058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85058/
Summaries are generated and may contain mistakes; the official description above is the record.
