CVE-2026-85088 Security feature bypass in Apache Thrift
Attackers with a valid CA-signed certificate can bypass hostname verification in Apache Thrift C++ and D clients by exploiting Common Name fallback logic.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-85088?
CVE-2026-85088 is a medium-severity vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Validation of Certificate with Host Mismatch in the C++ and D libraries of Apache Thrift.
Both libraries install a default access manager for client sockets — TSSLSocketFactory does so in C++, and the accessManager property does so in D — which compares the peer certificate against the host
name that was connected to. That comparison walks the subjectAltName dNSName entries first and consults the certificate Common Name afterwards. A name that does not match yields a "skip" result rather than
a rejection, so a certificate whose subjectAltName entries are all present and all non-matching falls through to the Common Name, which can then satisfy the check.
RFC 6125 section 6.4.4, and RFC 9525 section 2, require that the Common Name is not consulted when a dNSName subjectAltName is present. A certificate carrying subjectAltName entries for one name and a
Common Name for another is therefore accepted for a connection to the second name.
Exploitation requires an attacker positioned on the network path who holds a certificate that chains to a certificate authority in the client's trust store and whose Common Name matches the connected host
name. Public certificate authorities have not issued on Common Name alone for many years, so this is principally a concern for deployments using a private or enterprise public-key infrastructure.
This issue affects the C++ library of Apache Thrift from 0.7.0 through 0.24.0 and the D library from 0.9.0 through 0.24.0. Users should upgrade to 0.25.0.
Which versions are affected by CVE-2026-85088?
1 open source package ship an affected version, including thrift.
| Package | Affected | Fixed in |
|---|---|---|
thrift Bitnami | All versions | 0.25.0 |
How do I fix CVE-2026-85088?
Upgrade thrift to 0.25.0 or later.
Is CVE-2026-85088 being exploited?
There is no known exploitation of CVE-2026-85088 in the wild and no public exploit code.
Sources
Also known as AZL-106548, BIT-thrift-2026-85088, DEBIAN-CVE-2026-85088, ECHO-b211-92e6-3d9d, GHSA-4xmj-xwhr-jcj2, MINI-f29v-g78v-34m8 and 1 more.