# CVE-2026-85124: @fastify/http-proxy vulnerable to prefix escape via backslash dot-segments

> An unauthenticated attacker can bypass proxy prefix restrictions using backslash dot-segments to access hidden internal upstream endpoints.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Sep 2026
- **Updated:** 3 Sep 2026
- **Also known as:** GHSA-qv33-689p-2xq5

## What is CVE-2026-85124?

CVE-2026-85124 is a high-severity path traversal vulnerability in @fastify/http-proxy, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/http-proxy versions before 11.6.2 do not validate proxied HTTP request paths for backslash based dot-segments before forwarding them to the configured upstream. The plain HTTP request handler skips the destination validation that the WebSocket path performs, and the underlying reply-from library only rejects forward-slash traversal, so a request containing backslash dot-segments can escape the boundary set by the prefix and rewritePrefix options. An unauthenticated network attacker can use this to reach upstream paths that were meant to stay hidden behind the proxy, resulting in disclosure of internal endpoints. This is a path traversal issue (CWE-22). Users should upgrade to @fastify/http-proxy 11.6.2 or later.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-85124?

It affects 1 product.


Products: Fastify Fastify\/Http-Proxy.

## How do I fix CVE-2026-85124?

No fix has been published for CVE-2026-85124 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85124 being exploited?

There is no known exploitation of CVE-2026-85124 in the wild and no public exploit code.

## Other vulnerabilities in @fastify/http-proxy

- [CVE-2026-16117](https://insights.sbomify.com/CVE-2026-16117/): @fastify/http-proxy vulnerable to prefix escape via URL-encoded characters (critical 10.0)
- [CVE-2026-33805](https://insights.sbomify.com/CVE-2026-33805/): @fastify/reply-from vulnerable to connection header abuse enabling stripping of proxy-added headers (critical 9.0)
- [CVE-2026-15631](https://insights.sbomify.com/CVE-2026-15631/): @fastify/http-proxy vulnerable to prefix escape via WebSocket path traversal (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85124 and fix it if it is affected.

What it is: CVE-2026-85124 is a high-severity path traversal vulnerability in @fastify/http-proxy, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85124 in the wild and no public exploit code.

Affected product: @fastify/http-proxy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85124/ (Markdown: https://insights.sbomify.com/CVE-2026-85124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85124
- OSV: https://osv.dev/vulnerability/CVE-2026-85124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85124/
Summaries are generated and may contain mistakes; the official description above is the record.
