# CVE-2026-85152: undici vulnerable to cross-origin cache poisoning via missing origin isolation in interceptors

> Attackers can poison the cache to serve responses from one origin to another, causing information disclosure and authentication bypass in undici.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-85152, ECHO-60b6-e448-56a4, GHSA-vp8m-p9jh-q5pm, MINI-3c4r-7wv4-wqvg, MINI-76rm-qph7-r2v6, MINI-prjv-h5fh-8xjq, MINI-x858-5p6x-cpc4, MINI-xxv9-px6r-32cg, ROOT-APP-NPM-CVE-2026-85152, UBUNTU-CVE-2026-85152

## What is CVE-2026-85152?

CVE-2026-85152 is a high-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici 8.10.0 omits the destination origin from the cache and request-deduplication keys when the cache or deduplicate interceptor is composed directly onto a Client or Pool. Because the internal cache key falls back to an empty origin string, a cacheable or in-flight response from one upstream origin is returned for a request to a different, trusted origin whenever the method, path, and relevant headers match, which permits cross-origin information disclosure and persistent cache poisoning. The reporter demonstrated a full authentication bypass in which a JWT signed with an attacker-controlled key was accepted as belonging to a trusted issuer, and the trusted origin was never contacted. This is a regression introduced in 8.10.0 and affects undici versions from 8.10.0 up to 8.10.2. Applications using an Agent, which carries the origin in its dispatch options, are not affected. Users should upgrade to undici 8.10.2.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-85152?

2 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 8.10.0 | 8.10.2 |
| `undici` | npm | From 8.10.0 | 8.10.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-85152?

Upgrade undici to 8.10.2 or later.

## Is CVE-2026-85152 being exploited?

There is no known exploitation of CVE-2026-85152 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85152 and fix it if it is affected.

What it is: CVE-2026-85152 is a high-severity vulnerability in Nodejs Undici, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85152 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 8.10.0; fixed in 8.10.2
- undici (npm): affected from 8.10.0; fixed in 8.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85152/ (Markdown: https://insights.sbomify.com/CVE-2026-85152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85152
- OSV: https://osv.dev/vulnerability/CVE-2026-85152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85152/
Summaries are generated and may contain mistakes; the official description above is the record.
