# CVE-2026-85185: Path traversal in LXD btrfs storage driver allows arbitrary file deletion and write on host as root

> Authenticated users can delete or write arbitrary host files as root via path traversal in the btrfs storage driver, leading to host compromise.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-85185, GHSA-27q7-qwhm-c34p, UBUNTU-CVE-2026-85185

## What is CVE-2026-85185?

CVE-2026-85185 is a critical path traversal vulnerability in Canonical LXD, published on 28 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Path traversal in the btrfs storage driver in Canonical LXD versions 4.0.2 and later (fixed in 4.0.14, 5.0.10, 5.21.8 and 6.10) on Linux allows an authenticated client with permission to create instances in a project to delete arbitrary files on the host as root. On hosts whose root filesystem is btrfs, the client can also place attacker-controlled content at arbitrary host paths, leading to full host compromise. The client does this with a crafted subvolume path containing ../ sequences, sent in either of two ways: in the optimized_header.yaml of an optimized btrfs backup, or in the btrfs migration header sent by a malicious migration source.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-85185?


## How do I fix CVE-2026-85185?

Upgrade to a fixed version.

## Is CVE-2026-85185 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85185 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85185 and fix it if it is affected.

What it is: CVE-2026-85185 is a critical path traversal vulnerability in Canonical LXD, published on 28 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85185 exists.

Affected product: Canonical LXD. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85185/ (Markdown: https://insights.sbomify.com/CVE-2026-85185/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85185
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85185
- OSV: https://osv.dev/vulnerability/CVE-2026-85185

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85185/
Summaries are generated and may contain mistakes; the official description above is the record.
