CVE-2026-85228 Integer overflow in tensor buffer validation in Deep Java Library
Remote attackers can exploit an integer overflow in DJL to read adjacent memory or cause denial of service via crafted tensor payloads.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-85228?
CVE-2026-85228 is a high-severity vulnerability in Amazon Deep Java Library, published on 10 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An integer overflow in the tensor buffer validation component in Amazon Deep Java Library (DJL) from 0.13.0 through 0.36.0 on all platforms might allow a remote unauthenticated actor to obtain information from adjacent process memory or cause a denial of service via a crafted tensor payload.
To remediate this issue, users should upgrade to version 0.37.0 or above.
Weakness: CWE-190
Which versions are affected by CVE-2026-85228?
How do I fix CVE-2026-85228?
No fix has been published for CVE-2026-85228 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-85228 being exploited?
There is no known exploitation of CVE-2026-85228 in the wild and no public exploit code.
Sources
Also known as GHSA-5mvm-7cx8-x4wf.