{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-85228 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-85228 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85228 is a high-severity vulnerability in Amazon Deep Java Library, published on 10 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-85228 and fix it if it is affected.\n\nWhat it is: CVE-2026-85228 is a high-severity vulnerability in Amazon Deep Java Library, published on 10 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-85228 in the wild and no public exploit code.\n\nAffected product: Amazon Deep Java Library. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85228/ (Markdown: https://insights.sbomify.com/CVE-2026-85228/index.md)","id":"CVE-2026-85228","markdown":"https://insights.sbomify.com/CVE-2026-85228/index.md","name":"CVE-2026-85228","record":{"aliases":["GHSA-5mvm-7cx8-x4wf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java deep learning library","requires_auth":"none","summary":"Remote attackers can exploit an integer overflow in DJL to read adjacent memory or cause denial of service via crafted tensor payloads.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"An integer overflow in the tensor buffer validation component in Amazon Deep Java Library (DJL) from 0.13.0 through 0.36.0 on all platforms might allow a remote unauthenticated actor to obtain information from adjacent process memory or cause a denial of service via a crafted tensor payload.\n\nTo remediate this issue, users should upgrade to version 0.37.0 or above.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Integer overflow in tensor buffer validation in Deep Java Library","id":"CVE-2026-85228","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Apache SkyWalking: CWE-79 stored XSS in Booster UI dashboard widgets (incomplete fix of CVE-2025-54057)","id":"CVE-2026-85229"},"packages":[],"prev":{"headline":"Reflected Cross-Site Scripting in MISP Event Filtering via taggedAttributes and galaxyAttachedAttributes Parameters","id":"CVE-2026-85227"},"products":["Deep Java Library"],"published":"2026-09-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-10","vendors":["Amazon"]},"summary":"Remote attackers can exploit an integer overflow in DJL to read adjacent memory or cause denial of service via crafted tensor payloads.","url":"https://insights.sbomify.com/CVE-2026-85228/"}