# CVE-2026-85228: Integer overflow in tensor buffer validation in Deep Java Library

> Remote attackers can exploit an integer overflow in DJL to read adjacent memory or cause denial of service via crafted tensor payloads.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** GHSA-5mvm-7cx8-x4wf

## What is CVE-2026-85228?

CVE-2026-85228 is a high-severity vulnerability in Amazon Deep Java Library, published on 10 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An integer overflow in the tensor buffer validation component in Amazon Deep Java Library (DJL) from 0.13.0 through 0.36.0 on all platforms might allow a remote unauthenticated actor to obtain information from adjacent process memory or cause a denial of service via a crafted tensor payload.

To remediate this issue, users should upgrade to version 0.37.0 or above.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-85228?


## How do I fix CVE-2026-85228?

No fix has been published for CVE-2026-85228 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85228 being exploited?

There is no known exploitation of CVE-2026-85228 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85228 and fix it if it is affected.

What it is: CVE-2026-85228 is a high-severity vulnerability in Amazon Deep Java Library, published on 10 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85228 in the wild and no public exploit code.

Affected product: Amazon Deep Java Library. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85228/ (Markdown: https://insights.sbomify.com/CVE-2026-85228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85228
- OSV: https://osv.dev/vulnerability/CVE-2026-85228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85228/
Summaries are generated and may contain mistakes; the official description above is the record.
