CVE-2026-85229 Apache SkyWalking: CWE-79 stored XSS in Booster UI dashboard widgets (incomplete fix of CVE-2025-54057)
Stored XSS in SkyWalking Booster UI allows attackers to execute scripts in victim browsers, requiring an upgrade to Horizon UI.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-85229?
CVE-2026-85229 is a medium-severity cross-site scripting vulnerability in Apache SkyWalking, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
** UNSUPPORTED WHEN ASSIGNED ** Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache SkyWalking Booster UI.
This issue affects Apache SkyWalking UI : from 10.2.0 through 10.4.0.
Users are recommended to upgrade to Horizon UI 1.0.0, which fixes the issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-85229?
How do I fix CVE-2026-85229?
No fix has been published for CVE-2026-85229 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-85229 being exploited?
There is no known exploitation of CVE-2026-85229 in the wild and no public exploit code.
Sources
Also known as GHSA-26wm-72r9-xfwc.