{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-85229 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-85229 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85229 is a medium-severity cross-site scripting vulnerability in Apache SkyWalking, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-85229 and fix it if it is affected.\n\nWhat it is: CVE-2026-85229 is a medium-severity cross-site scripting vulnerability in Apache SkyWalking, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-85229 in the wild and no public exploit code.\n\nAffected product: Apache SkyWalking. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85229/ (Markdown: https://insights.sbomify.com/CVE-2026-85229/index.md)","id":"CVE-2026-85229","markdown":"https://insights.sbomify.com/CVE-2026-85229/index.md","name":"CVE-2026-85229","record":{"aliases":["GHSA-26wm-72r9-xfwc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"SkyWalking UI","requires_auth":"none","summary":"Stored XSS in SkyWalking Booster UI allows attackers to execute scripts in victim browsers, requiring an upgrade to Horizon UI.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache SkyWalking Booster UI.\n\nThis issue affects Apache SkyWalking UI : from 10.2.0 through 10.4.0.\n\nUsers are recommended to upgrade to Horizon UI 1.0.0, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Apache SkyWalking: CWE-79 stored XSS in Booster UI dashboard widgets (incomplete fix of CVE-2025-54057)","id":"CVE-2026-85229","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"MISP Dashboard Button Widget Allows Persistent JavaScript URL Injection","id":"CVE-2026-85230"},"packages":[],"prev":{"headline":"Integer overflow in tensor buffer validation in Deep Java Library","id":"CVE-2026-85228"},"products":["Apache SkyWalking"],"published":"2026-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-08","vendors":["Apache Software Foundation"]},"summary":"Stored XSS in SkyWalking Booster UI allows attackers to execute scripts in victim browsers, requiring an upgrade to Horizon UI.","url":"https://insights.sbomify.com/CVE-2026-85229/"}