CVE-2026-85241 SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorization
Remote attackers can bypass authorization checks to modify graph data in SpecterOps BloodHound, requiring an upgrade to secure the application.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-85241?
CVE-2026-85241 is a medium-severity missing authorization vulnerability in SpecterOps BloodHound, published on 3 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.
Which versions are affected by CVE-2026-85241?
How do I fix CVE-2026-85241?
No fix has been published for CVE-2026-85241 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-85241 being exploited?
There is no known exploitation of CVE-2026-85241 in the wild and no public exploit code.
Sources
Also known as GHSA-x4wv-m72p-pcf5.