{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-85241 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-85241 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85241 is a medium-severity missing authorization vulnerability in SpecterOps BloodHound, published on 3 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-85241 and fix it if it is affected.\n\nWhat it is: CVE-2026-85241 is a medium-severity missing authorization vulnerability in SpecterOps BloodHound, published on 3 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-85241 in the wild and no public exploit code.\n\nAffected product: SpecterOps BloodHound. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85241/ (Markdown: https://insights.sbomify.com/CVE-2026-85241/index.md)","id":"CVE-2026-85241","markdown":"https://insights.sbomify.com/CVE-2026-85241/index.md","name":"CVE-2026-85241","record":{"aliases":["GHSA-x4wv-m72p-pcf5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"BloodHound graph server","requires_auth":"low_privilege","summary":"Remote attackers can bypass authorization checks to modify graph data in SpecterOps BloodHound, requiring an upgrade to secure the application.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"},{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorization","id":"CVE-2026-85241","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":0,"n_references":7,"next":{"headline":"Server-Side Request Forgery via Favicon Redirect to Local Network Resources in PlaywrightCapture","id":"CVE-2026-85242"},"packages":[],"prev":{"headline":"MISP Event Template Definition Validation Bypass Allows Persistent Denial of Service","id":"CVE-2026-85239"},"products":["BloodHound"],"published":"2026-09-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-04","vendors":["SpecterOps"]},"summary":"Remote attackers can bypass authorization checks to modify graph data in SpecterOps BloodHound, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2026-85241/"}