# CVE-2026-85241: SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorization

> Remote attackers can bypass authorization checks to modify graph data in SpecterOps BloodHound, requiring an upgrade to secure the application.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** GHSA-x4wv-m72p-pcf5

## What is CVE-2026-85241?

CVE-2026-85241 is a medium-severity missing authorization vulnerability in SpecterOps BloodHound, published on 3 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2026-85241?


## How do I fix CVE-2026-85241?

No fix has been published for CVE-2026-85241 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85241 being exploited?

There is no known exploitation of CVE-2026-85241 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85241 and fix it if it is affected.

What it is: CVE-2026-85241 is a medium-severity missing authorization vulnerability in SpecterOps BloodHound, published on 3 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85241 in the wild and no public exploit code.

Affected product: SpecterOps BloodHound. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85241/ (Markdown: https://insights.sbomify.com/CVE-2026-85241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85241
- OSV: https://osv.dev/vulnerability/CVE-2026-85241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85241/
Summaries are generated and may contain mistakes; the official description above is the record.
