{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-85243 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-85243 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85243 is a medium-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-85243 and fix it if it is affected.\n\nWhat it is: CVE-2026-85243 is a medium-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-85243 in the wild and no public exploit code.\n\nAffected product: Apache Camel. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85243/ (Markdown: https://insights.sbomify.com/CVE-2026-85243/index.md)","id":"CVE-2026-85243","markdown":"https://insights.sbomify.com/CVE-2026-85243/index.md","name":"CVE-2026-85243","record":{"aliases":["GHSA-rgg6-2q97-gxhm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Camel library","requires_auth":"none","summary":"Attackers can bypass integrity checks in Apache Camel Crypto PGP by using legacy packet types, allowing undetected message tampering.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-354","name":"Improper Validation of Integrity Check Value"}],"description":"Improper Validation of Integrity Check Value vulnerability in Apache Camel Crypto PGP component.\n\nThis issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1.\n\nunmarshal() verified the modification detection code only when the message was an OpenPGP symmetrically encrypted integrity protected data packet. The older symmetrically encrypted data packet carries no such code, and OpenPGP's CFB mode is malleable without one, so a message using that packet skipped the check altogether. The packet type is chosen by whoever produced the message, which left the sender - or anyone able to rewrite the message in transit - deciding whether the integrity check applied at all. The existing integrity option governs marshalling only and had no decrypt-side counterpart, so a deployment could not require integrity protection on the messages it accepted.\n\nUpgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. A requireIntegrityProtection option, defaulting to true, now rejects a message that is not integrity protected. Note that signatureVerificationOption still defaults to optional, so a message carrying no signature is accepted; the two options together are what give a decrypted message authenticity and not only confidentiality. For deployments that cannot upgrade immediately, reject messages that do not use the integrity protected packet before they reach the data format. Routes that must interoperate with a sender still emitting the legacy packet should set requireIntegrityProtection=false after upgrading, and treat the decrypted content as unauthenticated.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2026-10-19","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-19T10:01:57Z","kind":"github_poc","ref":"https://github.com/oscerd/CVE-2026-85243","stars":0,"title":"Reproducer for CVE-2026-85243 — Apache Camel camel-crypto-pgp integrity verification downgrade (CWE-354); Spring Boot + Quarkus, affected vs fixed"}],"tier":"poc_unverified"},"has_fix":false,"headline":"Apache Camel: Camel-Crypto-PGP Integrity Verification Downgrade via Attacker-Controlled Message Structure","id":"CVE-2026-85243","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"Apache Camel: Camel-Thrift Cross-Exchange Data Disclosure via a Shared Deserialization Target","id":"CVE-2026-85245"},"packages":[],"prev":{"headline":"Server-Side Request Forgery via Favicon Redirect to Local Network Resources in PlaywrightCapture","id":"CVE-2026-85242"},"products":["Apache Camel"],"published":"2026-10-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-19","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass integrity checks in Apache Camel Crypto PGP by using legacy packet types, allowing undetected message tampering.","url":"https://insights.sbomify.com/CVE-2026-85243/"}