# CVE-2026-85243: Apache Camel: Camel-Crypto-PGP Integrity Verification Downgrade via Attacker-Controlled Message Structure

> Attackers can bypass integrity checks in Apache Camel Crypto PGP by using legacy packet types, allowing undetected message tampering.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-rgg6-2q97-gxhm

## What is CVE-2026-85243?

CVE-2026-85243 is a medium-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Validation of Integrity Check Value vulnerability in Apache Camel Crypto PGP component.

This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1.

unmarshal() verified the modification detection code only when the message was an OpenPGP symmetrically encrypted integrity protected data packet. The older symmetrically encrypted data packet carries no such code, and OpenPGP's CFB mode is malleable without one, so a message using that packet skipped the check altogether. The packet type is chosen by whoever produced the message, which left the sender - or anyone able to rewrite the message in transit - deciding whether the integrity check applied at all. The existing integrity option governs marshalling only and had no decrypt-side counterpart, so a deployment could not require integrity protection on the messages it accepted.

Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. A requireIntegrityProtection option, defaulting to true, now rejects a message that is not integrity protected. Note that signatureVerificationOption still defaults to optional, so a message carrying no signature is accepted; the two options together are what give a decrypted message authenticity and not only confidentiality. For deployments that cannot upgrade immediately, reject messages that do not use the integrity protected packet before they reach the data format. Routes that must interoperate with a sender still emitting the legacy packet should set requireIntegrityProtection=false after upgrading, and treat the decrypted content as unauthenticated.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2026-85243?


## How do I fix CVE-2026-85243?

No fix has been published for CVE-2026-85243 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85243 being exploited?

There is no known exploitation of CVE-2026-85243 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-85243 — Apache Camel camel-crypto-pgp integrity verification downgrade (CWE-354); Spring Boot + Quarkus, affected vs fixed (github_poc): https://github.com/oscerd/CVE-2026-85243

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85243 and fix it if it is affected.

What it is: CVE-2026-85243 is a medium-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85243 in the wild and no public exploit code.

Affected product: Apache Camel. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85243/ (Markdown: https://insights.sbomify.com/CVE-2026-85243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85243
- OSV: https://osv.dev/vulnerability/CVE-2026-85243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85243/
Summaries are generated and may contain mistakes; the official description above is the record.
