# CVE-2026-85279: Notepad++: Stack Buffer Overflow in Plugin Lexer Loading via Unchecked GetLexerCount() Return Value

> A malicious plugin can trigger a stack buffer overflow in Notepad++, allowing arbitrary code execution within the application process.

- **Severity:** High 8.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-h2wq-6x75-h8q2

## What is CVE-2026-85279?

CVE-2026-85279 is a high-severity memory corruption vulnerability in notepad-plus-plus, published on 22 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Notepad++ is a free and open-source source code editor. Prior to 8.9.8, Notepad++ contains a stack buffer overflow in PluginsManager::loadPluginFromPath in PowerEditor/src/MISC/PluginsManager/PluginsManager.cpp because the plugin-supplied GetLexerCount() result controls a loop that writes to containers[30] without enforcing NB_MAX_EXTERNAL_LANG. A malicious or compromised plugin that reports more than 30 lexers can write beyond the stack array and corrupt control data, which can permit arbitrary code execution in the Notepad++ process context. This issue is fixed in version 8.9.8.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-85279?


## How do I fix CVE-2026-85279?

No fix has been published for CVE-2026-85279 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85279 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85279 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85279 and fix it if it is affected.

What it is: CVE-2026-85279 is a high-severity memory corruption vulnerability in notepad-plus-plus, published on 22 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85279 exists.

Affected product: notepad-plus-plus. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85279/ (Markdown: https://insights.sbomify.com/CVE-2026-85279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85279
- OSV: https://osv.dev/vulnerability/CVE-2026-85279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85279/
Summaries are generated and may contain mistakes; the official description above is the record.
