{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-85301 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-85301 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85301 is a medium-severity authentication bypass vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-85301 and fix it if it is affected.\n\nWhat it is: CVE-2026-85301 is a medium-severity authentication bypass vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-85301 in the wild and no public exploit code.\n\nAffected product: Apache Camel. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85301/ (Markdown: https://insights.sbomify.com/CVE-2026-85301/index.md)","id":"CVE-2026-85301","markdown":"https://insights.sbomify.com/CVE-2026-85301/index.md","name":"CVE-2026-85301","record":{"aliases":["GHSA-73pw-28wr-vh7r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Camel integration framework","requires_auth":"none","summary":"Attackers can bypass authentication in Apache Camel Keycloak integrations if the introspection endpoint omits the issuer claim, allowing unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Improper Authentication vulnerability in Apache Camel Keycloak component.\n\nThis issue affects Apache Camel: from 4.15.0 before 4.18.5, from 4.19.0 before 4.22.1.\n\nThe security processor validated the issuer of an introspected token only when the introspection response actually carried an iss claim. When the claim was absent the check was skipped rather than treated as a failure, so a token that the configured issuer did not mint could be accepted provided the introspection endpoint answered without naming an issuer. Reaching this requires an introspection endpoint that omits iss and accepts tokens from more than one issuer, which is not the default Keycloak arrangement, hence the low severity; where that arrangement exists the consequence is that the deployment authenticates a caller it should have rejected.\n\nUpgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. An absent iss claim is now treated as a validation failure rather than as a reason to skip the check. For deployments that cannot upgrade immediately, ensure the introspection endpoint returns the iss claim, and that it serves exactly one issuer.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2026-10-20","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-20T11:30:26Z","kind":"github_poc","ref":"https://github.com/oscerd/CVE-2026-85301","stars":0,"title":"Reproducer for CVE-2026-85301 — Apache Camel camel-keycloak issuer validation bypass (CWE-287). Camel Spring Boot + Camel Quarkus."}],"tier":"poc_unverified"},"has_fix":false,"headline":"Apache Camel: Camel-Keycloak Issuer Validation Bypass When the Introspection Response Omits the iss Claim","id":"CVE-2026-85301","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"WordPress WPKoi Templates for Elementor plugin \u003c= 3.7.2 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2026-85302"},"packages":[],"prev":{"headline":"Apache Camel: Camel-PQC Private Key Disclosure via Key Material Written with Default File Permissions","id":"CVE-2026-85300"},"products":["Apache Camel"],"published":"2026-10-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-19","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass authentication in Apache Camel Keycloak integrations if the introspection endpoint omits the issuer claim, allowing unauthorized access.","url":"https://insights.sbomify.com/CVE-2026-85301/"}