{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-85317 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-85317 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85317 is a medium-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-85317 and fix it if it is affected.\n\nWhat it is: CVE-2026-85317 is a medium-severity vulnerability in Apache Camel, published on 19 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-85317 in the wild and no public exploit code.\n\nAffected product: Apache Camel. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85317/ (Markdown: https://insights.sbomify.com/CVE-2026-85317/index.md)","id":"CVE-2026-85317","markdown":"https://insights.sbomify.com/CVE-2026-85317/index.md","name":"CVE-2026-85317","record":{"aliases":["GHSA-5q96-qxg9-rmrw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Camel HTTP component","requires_auth":"none","summary":"Apache Camel's global OAuth2 token cache may serve tokens with incorrect scopes or resources, potentially exposing data or bypassing authorization checks.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-524","name":"Use of Cache Containing Sensitive Information"}],"description":"Use of Cache Containing Sensitive Information vulnerability in Apache Camel HTTP component.\n\nThis issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1.\n\nThe OAuth2 client token cache is global to the JVM, and its key omitted several of the fields that determine what a token actually authorises: the requested scope, the resource indicator, and the token endpoint the token was obtained from. Two endpoints differing only in those fields therefore shared a cache entry, and an endpoint could be served a token minted for a different scope, a different resource, or by a different authorization server. The consequence is a request carrying broader authority than the endpoint was configured for, or a token presented to a party it was not issued for. Reaching it requires a deployment that configures more than one OAuth2 endpoint differing in exactly those fields, which is why the severity is assessed low.\n\nUpgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The cache key now includes every field that shapes the token, so entries are no longer shared between endpoints that differ in any of them. For deployments that cannot upgrade immediately, run endpoints that differ in scope, resource indicator or token endpoint in separate JVMs so that they do not share the cache.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2026-10-21","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-21T08:52:55Z","kind":"github_poc","ref":"https://github.com/oscerd/CVE-2026-85317","stars":0,"title":"Reproducer for CVE-2026-85317 — Apache Camel camel-http OAuth2 token cache confusion (CWE-524). Camel Spring Boot."}],"tier":"poc_unverified"},"has_fix":false,"headline":"Apache Camel: Camel-HTTP OAuth2 Token Confusion via an Under-Keyed JVM-Global Token Cache","id":"CVE-2026-85317","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"Servicing Stack Updates Elevation of Privilege Vulnerability","id":"CVE-2026-85318"},"packages":[],"prev":{"headline":"Apache Camel: Camel-Platform-HTTP Unintended Proxy Mode via Prefix Path Matching","id":"CVE-2026-85316"},"products":["Apache Camel"],"published":"2026-10-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-19","vendors":["Apache Software Foundation"]},"summary":"Apache Camel's global OAuth2 token cache may serve tokens with incorrect scopes or resources, potentially exposing data or bypassing authorization checks.","url":"https://insights.sbomify.com/CVE-2026-85317/"}