CVE-2026-85500 `require_confirmed_with` is not enforced on the action and fails open on an unreadable attribute in AshAuthentication
Attackers can bypass email confirmation requirements to obtain sessions for unconfirmed users in AshAuthentication applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-85500?
CVE-2026-85500 is a critical authentication bypass vulnerability in team-alembic ash_authentication, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Authentication Bypass by Primary Weakness vulnerability in team-alembic AshAuthentication allows an unconfirmed user to obtain a session, defeating a mandatory email confirmation requirement.
AshAuthentication.Strategy.Password.Actions.check_user/2 decides whether the attribute named by require_confirmed_with is set using a bare is_nil(Map.get(user, value)). When that attribute is not selected on the loaded record Map.get/2 returns %Ash.NotLoaded{}, and when a field policy denies it for the current actor it returns %Ash.ForbiddenField{}. Neither is nil, so the rejection branch is skipped and sign-i
require_confirmed_with is enforced in two places, and neither holds in every configuration. sign_in_with_token and register are checked only inside AshAuthentication.Strategy.Password.Actions, not on the action itself, so any caller that invokes the action directly skips the check. An API layer such as AshGraphql or AshJsonApi invokes the action directly, so this applies to the default configuration. Where a check does run it compares the confirmation attribute against nil. That attribute holds %Ash.NotLoaded{} or %Ash.ForbiddenField{} when it sets select_by_default?: false, when an API layer narrows the read's select, or when a field policy hides it from the sign-in actor. Neither struct is nil, so those configurations read every user as confirmed.
This issue affects ash_authentication: from 4.3.8 before 4.15.0 and from 5.0.0-rc.0 before 5.0.0-rc.14.
Weakness: CWE-305
Which versions are affected by CVE-2026-85500?
1 open source package ship an affected version, including ash_authentication.
| Package | Affected | Fixed in |
|---|---|---|
ash_authentication Hex | From 4.3.8 | 4.15.0, 5.0.0-rc.14 |
How do I fix CVE-2026-85500?
Upgrade ash_authentication to a fixed version for your release line: 4.15.0 or 5.0.0-rc.14.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-85500 being exploited?
There is no known exploitation of CVE-2026-85500 in the wild and no public exploit code.
Sources
Also known as EEF-CVE-2026-85500, GHSA-fc47-6pgw-wh22.