{"answers":{"affected":"1 open source package ship an affected version, including ash_authentication.","exploited":"There is no known exploitation of CVE-2026-85500 in the wild and no public exploit code.","fix":"Upgrade ash_authentication to a fixed version for your release line: 4.15.0 or 5.0.0-rc.14.","what":"CVE-2026-85500 is a critical authentication bypass vulnerability in team-alembic ash_authentication, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-85500 and fix it if it is affected.\n\nWhat it is: CVE-2026-85500 is a critical authentication bypass vulnerability in team-alembic ash_authentication, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-85500 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ash_authentication (Hex): affected from 4.3.8; fixed in 4.15.0, 5.0.0-rc.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85500/ (Markdown: https://insights.sbomify.com/CVE-2026-85500/index.md)","id":"CVE-2026-85500","markdown":"https://insights.sbomify.com/CVE-2026-85500/index.md","name":"CVE-2026-85500","record":{"aliases":["EEF-CVE-2026-85500","GHSA-fc47-6pgw-wh22"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Elixir authentication library","requires_auth":"none","summary":"Attackers can bypass email confirmation requirements to obtain sessions for unconfirmed users in AshAuthentication applications.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-305","name":"Authentication Bypass by Primary Weakness"}],"description":"Authentication Bypass by Primary Weakness vulnerability in team-alembic AshAuthentication allows an unconfirmed user to obtain a session, defeating a mandatory email confirmation requirement.\n\nAshAuthentication.Strategy.Password.Actions.check_user/2 decides whether the attribute named by require_confirmed_with is set using a bare is_nil(Map.get(user, value)). When that attribute is not selected on the loaded record Map.get/2 returns %Ash.NotLoaded{}, and when a field policy denies it for the current actor it returns %Ash.ForbiddenField{}. Neither is nil, so the rejection branch is skipped and sign-i\n\nrequire_confirmed_with is enforced in two places, and neither holds in every configuration. sign_in_with_token and register are checked only inside AshAuthentication.Strategy.Password.Actions, not on the action itself, so any caller that invokes the action directly skips the check. An API layer such as AshGraphql or AshJsonApi invokes the action directly, so this applies to the default configuration. Where a check does run it compares the confirmation attribute against nil. That attribute holds %Ash.NotLoaded{} or %Ash.ForbiddenField{} when it sets select_by_default?: false, when an API layer narrows the read's select, or when a field policy hides it from the sign-in actor. Neither struct is nil, so those configurations read every user as confirmed.\n\nThis issue affects ash_authentication: from 4.3.8 before 4.15.0 and from 5.0.0-rc.0 before 5.0.0-rc.14.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"`require_confirmed_with` is not enforced on the action and fails open on an unreadable attribute in AshAuthentication","id":"CVE-2026-85500","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":1,"n_references":6,"next":{"headline":"Retrap: Novel Vulnerabilities to launch Algorithmic Complexity Attacks on DNSSEC","id":"CVE-2026-85501"},"packages":[{"ecosystem":"Hex","fixed":["4.15.0","5.0.0-rc.14"],"introduced":["4.3.8","5.0.0-rc.0"],"last_affected":[],"package":"ash_authentication","purl":"pkg:hex/ash_authentication","source":"EEF-CVE-2026-85500"}],"prev":{"headline":"Apache SkyWalking BanyanDB: Canopy does not enforce readonly-role restrictions on the /monitoring/* proxy","id":"CVE-2026-85499"},"products":["ash_authentication"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["team-alembic"]},"summary":"Attackers can bypass email confirmation requirements to obtain sessions for unconfirmed users in AshAuthentication applications.","url":"https://insights.sbomify.com/CVE-2026-85500/"}