{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85600 exists.","fix":"No fix has been published for CVE-2026-85600 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85600 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-admin2, published on 4 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-85600 and fix it if it is affected.\n\nWhat it is: CVE-2026-85600 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-admin2, published on 4 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85600 exists.\n\nAffected product: getgrav grav-plugin-admin2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85600/ (Markdown: https://insights.sbomify.com/CVE-2026-85600/index.md)","id":"CVE-2026-85600","markdown":"https://insights.sbomify.com/CVE-2026-85600/index.md","name":"CVE-2026-85600","record":{"aliases":["GHSA-7wfh-5xcc-cx4q","GHSA-96xm-c5hr-59rx"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav Admin plugin","requires_auth":"low_privilege","summary":"Stored XSS in Grav Admin allows attackers to execute scripts in admin sessions via malicious usernames, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Grav Admin (getgrav/grav-plugin-admin2) versions \u003c= 2.0.19 contain a stored cross-site scripting vulnerability in the tHtml() function (src/lib/stores/i18n.svelte.ts), which substitutes untrusted parameters such as usernames into translation templates before parsing the result as markdown. Grav's server-side username validation (DataUser::isValidUsername) blocks filesystem-dangerous characters but not \u003c, \u003e, \", or ', allowing an attacker to register a username containing an HTML payload. When an administrator views a UI surface that renders the username through tHtml()—such as the two-factor force-disable confirmation prompt or the 'page is locked' editor notice—the payload executes in their authenticated session. Fixed in 2.0.21.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Grav Admin before 2.0.21 Stored XSS via username","id":"CVE-2026-85600","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Grav Admin before 2.0.20 Cross-Site Scripting via marked.js","id":"CVE-2026-85601"},"packages":[],"prev":{"headline":"Grav Shortcode Core before 6.2.5 Stored XSS via unescaped parameters","id":"CVE-2026-85599"},"products":["grav-plugin-admin2"],"published":"2026-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-05","vendors":["getgrav"]},"summary":"Stored XSS in Grav Admin allows attackers to execute scripts in admin sessions via malicious usernames, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-85600/"}