# CVE-2026-85600: Grav Admin before 2.0.21 Stored XSS via username

> Stored XSS in Grav Admin allows attackers to execute scripts in admin sessions via malicious usernames, potentially leading to account takeover.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Sep 2026
- **Updated:** 5 Sep 2026
- **Also known as:** GHSA-7wfh-5xcc-cx4q, GHSA-96xm-c5hr-59rx

## What is CVE-2026-85600?

CVE-2026-85600 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-admin2, published on 4 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grav Admin (getgrav/grav-plugin-admin2) versions <= 2.0.19 contain a stored cross-site scripting vulnerability in the tHtml() function (src/lib/stores/i18n.svelte.ts), which substitutes untrusted parameters such as usernames into translation templates before parsing the result as markdown. Grav's server-side username validation (DataUser::isValidUsername) blocks filesystem-dangerous characters but not <, >, ", or ', allowing an attacker to register a username containing an HTML payload. When an administrator views a UI surface that renders the username through tHtml()—such as the two-factor force-disable confirmation prompt or the 'page is locked' editor notice—the payload executes in their authenticated session. Fixed in 2.0.21.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-85600?


## How do I fix CVE-2026-85600?

No fix has been published for CVE-2026-85600 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85600 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85600 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85600 and fix it if it is affected.

What it is: CVE-2026-85600 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-admin2, published on 4 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85600 exists.

Affected product: getgrav grav-plugin-admin2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85600/ (Markdown: https://insights.sbomify.com/CVE-2026-85600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85600
- OSV: https://osv.dev/vulnerability/CVE-2026-85600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85600/
Summaries are generated and may contain mistakes; the official description above is the record.
