# CVE-2026-85602: Grav Form Plugin before 9.1.20 reCAPTCHA v3 Authentication Bypass

> Attackers can bypass reCAPTCHA v3 protection in Grav Form plugin by submitting tokens under incorrect field names, allowing automated bot submissions.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Sep 2026
- **Updated:** 5 Sep 2026
- **Also known as:** GHSA-v453-9p95-fp34

## What is CVE-2026-85602?

CVE-2026-85602 is a critical vulnerability in getgrav grav-plugin-form, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Grav Form plugin (getgrav/grav-plugin-form) versions 8.0.6 through 9.1.19 select the reCAPTCHA version to validate based solely on which response field key is present in the submitted payload. On a site configured for reCAPTCHA v3, an anonymous attacker can place their v3 token under the v2 field name (g-recaptcha-response instead of token), causing validation to use the v2 branch, which never applies the score threshold or verifies the expected action. This results in a complete bypass of reCAPTCHA v3 bot protection. The issue is fixed in version 9.1.20.

Weakness: CWE-807 (Reliance on Untrusted Inputs in a Security Decision)

## Which versions are affected by CVE-2026-85602?


## How do I fix CVE-2026-85602?

No fix has been published for CVE-2026-85602 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85602 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85602 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85602 and fix it if it is affected.

What it is: CVE-2026-85602 is a critical vulnerability in getgrav grav-plugin-form, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85602 exists.

Affected product: getgrav grav-plugin-form. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85602/ (Markdown: https://insights.sbomify.com/CVE-2026-85602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85602
- OSV: https://osv.dev/vulnerability/CVE-2026-85602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85602/
Summaries are generated and may contain mistakes; the official description above is the record.
