# CVE-2026-85651: Trigger.dev before 4.5.2 Unauthorized Environment Access via Run Replay

> Authenticated attackers can inject task runs into other organizations' environments, consuming resources and polluting run history due to missing membership validation.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** GHSA-qxpp-qjg8-x4jv, GHSA-r87q-rjwf-c49g, MINI-4h96-x74v-p2mg

## What is CVE-2026-85651?

CVE-2026-85651 is a high-severity missing authorization vulnerability in triggerdotdev trigger.dev, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Trigger.dev versions before 4.5.2 fail to validate environment membership during run replay operations, allowing authenticated attackers to inject task runs into arbitrary environments. Attackers can replay their own runs into other organizations' or projects' environments to consume victim resources and pollute run history.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-85651?

2 open source packages ship an affected version, including trigger.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trigger.dev` | npm | All versions | 4.5.2 |
| `trigger.dev` | npm | All versions | 4.5.2 |

## How do I fix CVE-2026-85651?

Upgrade trigger.dev to 4.5.2 or later.

## Is CVE-2026-85651 being exploited?

There is no known exploitation of CVE-2026-85651 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85651 and fix it if it is affected.

What it is: CVE-2026-85651 is a high-severity missing authorization vulnerability in triggerdotdev trigger.dev, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85651 in the wild and no public exploit code.

Affected packages and fixed versions:
- trigger.dev (npm): affected all versions; fixed in 4.5.2
- trigger.dev (npm): affected all versions; fixed in 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85651/ (Markdown: https://insights.sbomify.com/CVE-2026-85651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85651
- OSV: https://osv.dev/vulnerability/CVE-2026-85651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85651/
Summaries are generated and may contain mistakes; the official description above is the record.
