# CVE-2026-85733: FrankenPHP: Docker images serve phpinfo() as the default index.php, leaking environment variables

> Default Docker images expose phpinfo() output, leaking environment variables and system configuration to attackers.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-cj57-c655-p798

## What is CVE-2026-85733?

CVE-2026-85733 is a medium-severity vulnerability in frankenphp, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FrankenPHP is a modern application server for PHP. Prior to 1.12.5, the official FrankenPHP Debian and Alpine Docker images include a default /app/public/index.php that executes phpinfo(). A derived image that does not overwrite this placeholder serves the diagnostics page in production and can disclose environment variables used for secrets, PHP configuration directives, loaded extensions, software versions, and system paths. Images built using the documented pattern with their own /app/public/index.php are not affected, and already derived images must be rebuilt or supplied with an application index to remove the exposed placeholder. This issue is fixed in version 1.12.5.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-85733?


## How do I fix CVE-2026-85733?

No fix has been published for CVE-2026-85733 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85733 being exploited?

There is no known exploitation of CVE-2026-85733 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85733 and fix it if it is affected.

What it is: CVE-2026-85733 is a medium-severity vulnerability in frankenphp, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85733 in the wild and no public exploit code.

Affected product: frankenphp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85733/ (Markdown: https://insights.sbomify.com/CVE-2026-85733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85733
- OSV: https://osv.dev/vulnerability/CVE-2026-85733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85733/
Summaries are generated and may contain mistakes; the official description above is the record.
