{"answers":{"affected":"3 open source packages ship an affected version, including lightrag-hku.","exploited":"There is no known exploitation of CVE-2026-85734 in the wild and no public exploit code.","fix":"Upgrade lightrag-hku to 1.5.5 or later.","what":"CVE-2026-85734 is a critical authentication bypass vulnerability in HKUDS LightRAG, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-85734 and fix it if it is affected.\n\nWhat it is: CVE-2026-85734 is a critical authentication bypass vulnerability in HKUDS LightRAG, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-85734 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5\n- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5\n- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85734/ (Markdown: https://insights.sbomify.com/CVE-2026-85734/index.md)","id":"CVE-2026-85734","markdown":"https://insights.sbomify.com/CVE-2026-85734/index.md","name":"CVE-2026-85734","record":{"aliases":["GHSA-frch-4w6v-q5xx","PYSEC-2026-4062"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"LightRAG API server","requires_auth":"none","summary":"Attackers can brute-force login credentials due to missing rate limits, gaining unauthorized access to documents and admin functions.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"}],"description":"LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.5.5, the POST /login endpoint in lightrag/api/lightrag_server.py does not impose a rate limit, account lockout, delay, or counter for failed authentication attempts. A network attacker can submit password guesses at full request speed until a valid account password is found. Successful credential recovery grants authenticated access to documents, the knowledge graph, and administrative operations. This issue is fixed in version 1.5.5.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LightRAG: No Rate Limiting on /login Endpoint Allows Brute-Force Attacks","id":"CVE-2026-85734","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"TREK: SSRF Guard Bypass via IPv6 Transition Addresses (NAT64/6to4)","id":"CVE-2026-85738"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.5"],"introduced":["0"],"last_affected":[],"package":"lightrag-hku","purl":null,"source":"GHSA-frch-4w6v-q5xx"},{"ecosystem":"PyPI","fixed":["1.5.5"],"introduced":["0"],"last_affected":[],"package":"lightrag-hku","purl":"pkg:pypi/lightrag-hku","source":"GHSA-frch-4w6v-q5xx"},{"ecosystem":"PyPI","fixed":["1.5.5"],"introduced":["0"],"last_affected":[],"package":"lightrag-hku","purl":"pkg:pypi/lightrag-hku","source":"PYSEC-2026-4062"}],"prev":{"headline":"FrankenPHP: Docker images serve phpinfo() as the default index.php, leaking environment variables","id":"CVE-2026-85733"},"products":["LightRAG"],"published":"2026-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-22","vendors":["HKUDS"]},"summary":"Attackers can brute-force login credentials due to missing rate limits, gaining unauthorized access to documents and admin functions.","url":"https://insights.sbomify.com/CVE-2026-85734/"}