# CVE-2026-85734: LightRAG: No Rate Limiting on /login Endpoint Allows Brute-Force Attacks

> Attackers can brute-force login credentials due to missing rate limits, gaining unauthorized access to documents and admin functions.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-frch-4w6v-q5xx, PYSEC-2026-4062

## What is CVE-2026-85734?

CVE-2026-85734 is a critical authentication bypass vulnerability in HKUDS LightRAG, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.5.5, the POST /login endpoint in lightrag/api/lightrag_server.py does not impose a rate limit, account lockout, delay, or counter for failed authentication attempts. A network attacker can submit password guesses at full request speed until a valid account password is found. Successful credential recovery grants authenticated access to documents, the knowledge graph, and administrative operations. This issue is fixed in version 1.5.5.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-85734?

3 open source packages ship an affected version, including lightrag-hku.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lightrag-hku` | PyPI | All versions | 1.5.5 |
| `lightrag-hku` | PyPI | All versions | 1.5.5 |
| `lightrag-hku` | PyPI | All versions | 1.5.5 |

## How do I fix CVE-2026-85734?

Upgrade lightrag-hku to 1.5.5 or later.

## Is CVE-2026-85734 being exploited?

There is no known exploitation of CVE-2026-85734 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85734 and fix it if it is affected.

What it is: CVE-2026-85734 is a critical authentication bypass vulnerability in HKUDS LightRAG, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85734 in the wild and no public exploit code.

Affected packages and fixed versions:
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85734/ (Markdown: https://insights.sbomify.com/CVE-2026-85734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85734
- OSV: https://osv.dev/vulnerability/CVE-2026-85734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85734/
Summaries are generated and may contain mistakes; the official description above is the record.
