# CVE-2026-85740: lightrag-hku: SSRF via IPv6-transition address bypass (NAT64, IPv4-compatible, 6to4) of the native-markdown image-download guard

> Attackers can bypass SSRF guards using IPv6 transition addresses to access internal resources in LightRAG deployments with NAT64/DNS64 routing.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-vv3m-f8x4-7377, PYSEC-2026-4064

## What is CVE-2026-85740?

CVE-2026-85740 is a high-severity server-side request forgery vulnerability in HKUDS LightRAG, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.5.5, _validated_addresses in lightrag/parser/markdown/parser.py evaluates the literal resolved address with ipaddress.is_global without consistently classifying an IPv4 address embedded in an IPv6 transition wrapper. A caller who can upload a Markdown or textpack document can supply an external image URL using NAT64 64:ff9b::/96 or an IPv4-compatible form that embeds a loopback, private, or cloud-metadata IPv4 address. On a deployment with compatible NAT64 or DNS64 routing, _download and _build_guarded_opener accept the wrapper and fetch the internal resource, whose body is then ingested. Current interpreter behavior already blocks some RFC 8215 and 6to4 forms, but the fixed guard handles all documented wrappers without becoming more permissive than the standard library. This issue is fixed in version 1.5.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-85740?

3 open source packages ship an affected version, including lightrag-hku.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lightrag-hku` | PyPI | All versions | 1.5.5 |
| `lightrag-hku` | PyPI | All versions | 1.5.5 |
| `lightrag-hku` | PyPI | All versions | 1.5.5 |

## How do I fix CVE-2026-85740?

Upgrade lightrag-hku to 1.5.5 or later.

## Is CVE-2026-85740 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85740 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85740 and fix it if it is affected.

What it is: CVE-2026-85740 is a high-severity server-side request forgery vulnerability in HKUDS LightRAG, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-85740 exists.

Affected packages and fixed versions:
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85740/ (Markdown: https://insights.sbomify.com/CVE-2026-85740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85740
- OSV: https://osv.dev/vulnerability/CVE-2026-85740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85740/
Summaries are generated and may contain mistakes; the official description above is the record.
