{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-85787 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-85787 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85787 is a high-severity SQL injection vulnerability in Amazon postgres-mcp-server, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-85787 and fix it if it is affected.\n\nWhat it is: CVE-2026-85787 is a high-severity SQL injection vulnerability in Amazon postgres-mcp-server, published on 4 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-85787 in the wild and no public exploit code.\n\nAffected product: Amazon postgres-mcp-server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85787/ (Markdown: https://insights.sbomify.com/CVE-2026-85787/index.md)","id":"CVE-2026-85787","markdown":"https://insights.sbomify.com/CVE-2026-85787/index.md","name":"CVE-2026-85787","record":{"aliases":["GHSA-f4f4-39r8-8gj4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL MCP server","requires_auth":"none","summary":"An attacker can modify data beyond read-only limits via crafted SQL in the Amazon postgres-mcp-server due to incomplete input validation.","user_interaction":"required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-184","name":"Incomplete List of Disallowed Inputs"}],"description":"An incomplete list of disallowed inputs in the SQL validation component in Amazon awslabs postgres-mcp-server before  version 1.1.7 might allow an unauthenticated actor to modify data beyond the read-only scope by placing crafted SQL into the content that is submitted when an authenticated user interacts with the MCP server.\n\nTo remediate this issue, users should upgrade to version 1.1.7 or above.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"An incomplete list of disallowed inputs in the SQL validation component of Amazon awslabs postgres-mcp-server","id":"CVE-2026-85787","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Incomplete list of disallowed inputs in awslabs mysql-mcp-server","id":"CVE-2026-85788"},"packages":[],"prev":{"headline":"Incomplete fix for CVE-2026-75936 memory-amplification denial of service in Amazon ion-java","id":"CVE-2026-85786"},"products":["postgres-mcp-server"],"published":"2026-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-08","vendors":["Amazon"]},"summary":"An attacker can modify data beyond read-only limits via crafted SQL in the Amazon postgres-mcp-server due to incomplete input validation.","url":"https://insights.sbomify.com/CVE-2026-85787/"}