# CVE-2026-8589: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

> An authenticated user can exploit XSS in GitLab group settings to add unauthorized email addresses to another user's account, potentially leading to account takeover.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** BIT-gitlab-2026-8589, GHSA-q9j8-24p8-jq8j, MINI-3g6f-m4q6-gvgr, MINI-3qh4-4jw2-fxwq, MINI-3xpq-phw3-gwhg, MINI-427q-pqw9-p699, MINI-489w-m9rg-m49j, MINI-553j-ghhc-764q, MINI-69p8-86rr-6498, MINI-6mqq-2863-phjq, MINI-7f8x-mq4c-mg6w, MINI-7g7x-h7vv-mc9w, MINI-7mw8-vwgg-29xh, MINI-8234-2r8q-9h5x, MINI-8299-fmv7-7mhq, MINI-8f59-p2xp-2v59, MINI-8j9f-43pq-qfr2, MINI-8xph-rf47-7ggc, MINI-c4rv-fp34-99q8, MINI-c7v8-8vgx-hf79, MINI-c8m4-24x5-mpcc, MINI-cp43-hr2v-m2m4, MINI-cvcg-266x-4c3x, MINI-fjxw-w692-947g, MINI-fw3r-82qv-27fx, MINI-fwm8-h8x5-g53w, MINI-g36j-962x-9676, MINI-gxrc-5xcw-pjvw, MINI-h3hp-fwh6-3vh5, MINI-hcc4-7pj5-4g9g, MINI-hmfj-cx3h-cv86, MINI-hrg9-j6qj-pm22, MINI-jh4h-4hf9-4x5f, MINI-m3cx-wrf5-3wpv, MINI-q8jf-2pwg-c5p6, MINI-qgm6-4xg6-cq7c, MINI-qq5c-3cph-7x33, MINI-r23j-3rhr-cjcq, MINI-r667-5wgx-pg8m, MINI-vh6h-3gvh-2449, MINI-vp8w-g74h-w82x, MINI-w99q-vhvq-7pf7, MINI-wq8p-97pc-jr8w, MINI-x823-m8q8-wg39, MINI-xg3j-m3mv-2pcp, MINI-xq4x-hxhq-p3hh, UBUNTU-CVE-2026-8589

## What is CVE-2026-8589?

CVE-2026-8589 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 11 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 13.1.4 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that under certain conditions could have allowed an authenticated user to add unauthorized email addresses to a targeted user's account due to improper sanitization of user-supplied input in certain group setting fields.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-8589?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 13.1.4 | 18.10.8, 18.11.5, 19.0.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-8589?

Upgrade gitlab to a fixed version for your release line: 18.10.8, 18.11.5 or 19.0.2.

## Is CVE-2026-8589 being exploited?

There is no known exploitation of CVE-2026-8589 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8589 and fix it if it is affected.

What it is: CVE-2026-8589 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 11 Jun 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-8589 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 13.1.4; fixed in 18.10.8, 18.11.5, 19.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8589/ (Markdown: https://insights.sbomify.com/CVE-2026-8589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8589
- OSV: https://osv.dev/vulnerability/CVE-2026-8589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8589/
Summaries are generated and may contain mistakes; the official description above is the record.
