CVE-2026-85979 Command Injection in Puppet Enterprise
Authenticated administrators can inject shell commands executed as root, leading to full system compromise in Puppet Enterprise.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-85979?
CVE-2026-85979 is a high-severity command injection vulnerability in Perforce Software Puppet Enterprise, published on 11 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. Because the resulting commands are executed with root privileges, successful exploitation can lead to full compromise of the affected system.
It affects Puppet Enterprise 2023.8.0 through 2023.8.10 and Puppet Enterprise 2025.0.0 through 2025.11.2.
This has been resolved in Puppet Enterprise 2023.8.11 and Puppet Enterprise 2025.11.3.
Which versions are affected by CVE-2026-85979?
How do I fix CVE-2026-85979?
No fix has been published for CVE-2026-85979 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-85979 being exploited?
There is no known exploitation of CVE-2026-85979 in the wild and no public exploit code.
Sources
Also known as GHSA-j9jp-p256-9294, UBUNTU-CVE-2026-85979.