{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-85979 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-85979 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-85979 is a high-severity command injection vulnerability in Perforce Software Puppet Enterprise, published on 11 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-85979 and fix it if it is affected.\n\nWhat it is: CVE-2026-85979 is a high-severity command injection vulnerability in Perforce Software Puppet Enterprise, published on 11 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-85979 in the wild and no public exploit code.\n\nAffected product: Perforce Software Puppet Enterprise. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-85979/ (Markdown: https://insights.sbomify.com/CVE-2026-85979/index.md)","id":"CVE-2026-85979","markdown":"https://insights.sbomify.com/CVE-2026-85979/index.md","name":"CVE-2026-85979","record":{"aliases":["GHSA-j9jp-p256-9294","UBUNTU-CVE-2026-85979"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Puppet Enterprise","requires_auth":"high_privilege","summary":"Authenticated administrators can inject shell commands executed as root, leading to full system compromise in Puppet Enterprise.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Perforce","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. Because the resulting commands are executed with root privileges, successful exploitation can lead to full compromise of the affected system. \n\nIt affects Puppet Enterprise 2023.8.0 through 2023.8.10 and Puppet Enterprise 2025.0.0 through 2025.11.2.\n\nThis has been resolved in Puppet Enterprise 2023.8.11 and Puppet Enterprise 2025.11.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Command Injection in Puppet Enterprise","id":"CVE-2026-85979","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Unauthenticated Localhost Admin Panel in Auth0 AD/LDAP Connector","id":"CVE-2026-85981"},"packages":[],"prev":{"headline":"Unauthenticated Remote Code Execution in Akana API Platform","id":"CVE-2026-85978"},"products":["Puppet Enterprise"],"published":"2026-09-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-16","vendors":["Perforce Software"]},"summary":"Authenticated administrators can inject shell commands executed as root, leading to full system compromise in Puppet Enterprise.","url":"https://insights.sbomify.com/CVE-2026-85979/"}