# CVE-2026-85979: Command Injection in Puppet Enterprise

> Authenticated administrators can inject shell commands executed as root, leading to full system compromise in Puppet Enterprise.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-j9jp-p256-9294, UBUNTU-CVE-2026-85979

## What is CVE-2026-85979?

CVE-2026-85979 is a high-severity command injection vulnerability in Perforce Software Puppet Enterprise, published on 11 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Affected versions of Puppet Enterprise contain a command injection vulnerability. An authenticated user with Puppet administrative privileges can inject arbitrary shell commands by providing a specially crafted value for this parameter, which is passed to a shell execution context without sufficient sanitization. Because the resulting commands are executed with root privileges, successful exploitation can lead to full compromise of the affected system. 

It affects Puppet Enterprise 2023.8.0 through 2023.8.10 and Puppet Enterprise 2025.0.0 through 2025.11.2.

This has been resolved in Puppet Enterprise 2023.8.11 and Puppet Enterprise 2025.11.3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-269 (Improper Privilege Management), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-85979?


## How do I fix CVE-2026-85979?

No fix has been published for CVE-2026-85979 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-85979 being exploited?

There is no known exploitation of CVE-2026-85979 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-85979 and fix it if it is affected.

What it is: CVE-2026-85979 is a high-severity command injection vulnerability in Perforce Software Puppet Enterprise, published on 11 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-85979 in the wild and no public exploit code.

Affected product: Perforce Software Puppet Enterprise. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-85979/ (Markdown: https://insights.sbomify.com/CVE-2026-85979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-85979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-85979
- OSV: https://osv.dev/vulnerability/CVE-2026-85979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-85979/
Summaries are generated and may contain mistakes; the official description above is the record.
