# CVE-2026-86018: Part-DB: Authenticated Disk Exhaustion via Unbounded Server-Side Attachment Downloads


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-2whx-2cx7-qvq6

## What is CVE-2026-86018?

CVE-2026-86018 is a medium-severity vulnerability in Part-DB-server, published on 23 Oct 2026. 

### Official description

Part-DB is an open source inventory management system for electronic components. Prior to version 2.13.2, Part-DB allows authenticated users to bypass the configured maximum attachment file size when using the server-side “Download external file” attachment feature. When server-side attachment downloads are enabled, Part-DB downloads the remote file and streams it directly to disk without enforcing the configured MAX_ATTACHMENT_FILE_SIZE limit. As a result, an authenticated user who can create or edit attachments can cause Part-DB to store files larger than the configured maximum attachment size, potentially exhausting disk space and causing a denial of service. This issue has been patched in version 2.13.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-86018?


## How do I fix CVE-2026-86018?

No fix has been published for CVE-2026-86018 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-86018 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86018 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86018 and fix it if it is affected.

What it is: CVE-2026-86018 is a medium-severity vulnerability in Part-DB-server, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86018 exists.

Affected product: Part-DB-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86018/ (Markdown: https://insights.sbomify.com/CVE-2026-86018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86018
- OSV: https://osv.dev/vulnerability/CVE-2026-86018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86018/
Summaries are generated and may contain mistakes; the official description above is the record.
