# CVE-2026-86020: Part-DB: Spreadsheet Formula Injection in XLSX Part Exports


- **Severity:** Medium 4.6 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-hxw4-frfg-f8jw

## What is CVE-2026-86020?

CVE-2026-86020 is a medium-severity vulnerability in Part-DB-server, published on 23 Oct 2026. 

### Official description

Part-DB is an open source inventory management system for electronic components. Prior to version 2.13.2, Part-DB contains a spreadsheet formula injection vulnerability in the part import/export workflow. An authenticated user with permission to import parts can import a CSV file containing formula-prefixed values, such as =1+1, into user-controlled part fields. When the affected part is later exported as an XLSX spreadsheet, Part-DB writes the attacker-controlled value using PhpSpreadsheet's setCellValue() method without neutralising spreadsheet formula characters. As a result, the exported XLSX file contains an executable spreadsheet formula cell rather than a plain text value. If another user exports and opens the spreadsheet, the formula may be evaluated by their spreadsheet software. This issue has been patched in version 2.13.2.

Weakness: CWE-20 (Improper Input Validation), CWE-1236 (Improper Neutralization of Formula Elements in a CSV File)

## Which versions are affected by CVE-2026-86020?


## How do I fix CVE-2026-86020?

No fix has been published for CVE-2026-86020 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-86020 being exploited?

There is no known exploitation of CVE-2026-86020 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86020 and fix it if it is affected.

What it is: CVE-2026-86020 is a medium-severity vulnerability in Part-DB-server, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-86020 in the wild and no public exploit code.

Affected product: Part-DB-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86020/ (Markdown: https://insights.sbomify.com/CVE-2026-86020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86020
- OSV: https://osv.dev/vulnerability/CVE-2026-86020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86020/
Summaries are generated and may contain mistakes; the official description above is the record.
