# CVE-2026-86035: Weblate: Mercurial argument injection via repository filenames allows authenticated command execution

> Authenticated users can execute arbitrary commands via argument injection in Mercurial filenames within Weblate.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Sep 2026
- **Updated:** 2 Oct 2026
- **Also known as:** GHSA-327h-qqgm-qv55

## What is CVE-2026-86035?

CVE-2026-86035 is a high-severity command injection vulnerability in WeblateOrg weblate, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Weblate is a web-based continuous localization platform used to manage software translations. Weblate 4.11.1 through 2026.7.1 contains an argument-injection vulnerability in its Mercurial backend. Repository filenames beginning with - could be interpreted as Mercurial options instead of literal paths. An authenticated user with project-scoped component.edit permission could exploit this through a Mercurial-backed RESX component using the Update RESX files add-on. A later repository update could execute arbitrary commands with the privileges of the Weblate service account. This is a residual incomplete fix for CVE-2022-23915. This issue has been patched in version 2026.8.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-86035?


## How do I fix CVE-2026-86035?

No fix has been published for CVE-2026-86035 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-86035 being exploited?

There is no known exploitation of CVE-2026-86035 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86035 and fix it if it is affected.

What it is: CVE-2026-86035 is a high-severity command injection vulnerability in WeblateOrg weblate, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86035 in the wild and no public exploit code.

Affected product: WeblateOrg weblate. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86035/ (Markdown: https://insights.sbomify.com/CVE-2026-86035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86035
- OSV: https://osv.dev/vulnerability/CVE-2026-86035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86035/
Summaries are generated and may contain mistakes; the official description above is the record.
