# CVE-2026-86038: libp2p: Gossipsub StrictSign accepts attacker-signed messages as a victim RSA peer ID

> Attackers can forge message origins in libp2p Gossipsub by bypassing signature validation, leading to false attribution and potential abuse of trust mechanisms.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-c3gv-825q-fvmp

## What is CVE-2026-86038?

CVE-2026-86038 is a high-severity authentication bypass vulnerability in js-libp2p, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libp2p is a JavaScript implementation of the libp2p networking stack. From 15.0.0 until 16.0.5, @libp2p/gossipsub uses the default StrictSign policy in packages/gossipsub/src/utils/buildRawMessage.ts, where validateToRawMessage verifies a signature with attacker-controlled msg.key but skips binding that key to msg.from when the claimed author is an RSA peer ID that does not inline a public key. An unauthenticated attacker can place a victim RSA peer ID in msg.from, sign the message with the attacker's private key, and supply the attacker's public key in msg.key, causing the message to be accepted and propagated as authored by the victim. Applications that trust message.from for validators, authorization, accounting, moderation, reputation, or audit logging can process attacker-controlled data under false origin attribution. The issue is fixed in version 16.0.5.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-86038?

2 open source packages ship an affected version, including @libp2p/gossipsub.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@libp2p/gossipsub` | npm | From 15.0.0 | 16.0.5 |
| `@libp2p/gossipsub` | npm | From 15.0.0 | 16.0.5 |

## How do I fix CVE-2026-86038?

Upgrade @libp2p/gossipsub to 16.0.5 or later.

## Is CVE-2026-86038 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86038 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86038 and fix it if it is affected.

What it is: CVE-2026-86038 is a high-severity authentication bypass vulnerability in js-libp2p, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86038 exists.

Affected packages and fixed versions:
- @libp2p/gossipsub (npm): affected from 15.0.0; fixed in 16.0.5
- @libp2p/gossipsub (npm): affected from 15.0.0; fixed in 16.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86038/ (Markdown: https://insights.sbomify.com/CVE-2026-86038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86038
- OSV: https://osv.dev/vulnerability/CVE-2026-86038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86038/
Summaries are generated and may contain mistakes; the official description above is the record.
