CVE-2026-86039 libp2p: PeerStore accepts attacker-signed PeerRecords for a victim peer ID and stores certified attacker addresses

High 8.2 Published Updated

Attackers can poison the peer store with malicious addresses for victim peers, causing routing manipulation and connection failures in libp2p applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-86039?

CVE-2026-86039 is a high-severity vulnerability in js-libp2p, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

libp2p is a JavaScript implementation of the libp2p networking stack. From 8.0.0 until 12.0.24, @libp2p/peer-store in packages/peer-store/src/index.ts uses consumePeerRecord to verify a RecordEnvelope signature but does not require PeerRecord.peerId in the signed payload to equal the signer peer ID derived by RecordEnvelope.openAndCertify. The expectedPeer option checks only the envelope signer, and the gossipsub Peer Exchange path can provide the attacker's own peer ID as expectedPeer. An attacker can therefore sign a record with the attacker's key, place a victim peer ID and attacker-controlled multiaddrs in the payload, and have certified addresses stored for the victim. The poisoned addresses can cause address-book corruption, dial redirection or failure, routing manipulation, and reachability disruption, although the connection upgrade still verifies remote peer identity and prevents a complete identity takeover. The issue is fixed in version 12.0.24.

Weakness: CWE-345, CWE-290

Which versions are affected by CVE-2026-86039?

2 open source packages ship an affected version, including @libp2p/peer-store.

PackageAffectedFixed in
@libp2p/peer-store npmFrom 8.0.012.0.24
@libp2p/peer-store npmFrom 8.0.012.0.24

How do I fix CVE-2026-86039?

Upgrade @libp2p/peer-store to 12.0.24 or later.

Is CVE-2026-86039 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86039 exists.

Sources

Also known as GHSA-vrf4-mx87-p53w.

Is CVE-2026-86039 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free