# CVE-2026-8606: Server-Side Request Forgery in GitHub Enterprise Server via Advisory Package URL Endpoint

> Attackers can exploit SSRF in GitHub Enterprise Server to infer sensitive environment variables via internal service requests, requiring GitHub Packages to be enabled.

- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-3w49-fq5g-g3q6

## What is CVE-2026-8606?

CVE-2026-8606 is a high-severity server-side request forgery vulnerability in Github Enterprise Server, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed an attacker to cause the server to issue HTTP requests to internal services via the security advisories package lookup feature. By directing requests to an internal management service and measuring response timing, an attacker could infer the values of sensitive environment variables, including signing secrets and private keys. Exploitation required GitHub Packages to be enabled; on instances not running in private mode the vulnerability was exploitable without authentication, otherwise any authenticated user could exploit it. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21.1 and was fixed in versions 3.20.3, 3.19.7, 3.18.10, 3.17.16, and 3.16.19. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-8606?

It affects 1 product.


Products: Github Enterprise Server.

## How do I fix CVE-2026-8606?

No fix has been published for CVE-2026-8606 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-8606 being exploited?

There is no known exploitation of CVE-2026-8606 in the wild and no public exploit code.

## Other vulnerabilities in Github Enterprise Server

- [CVE-2024-4985](https://insights.sbomify.com/CVE-2024-4985/): Auth bypass in Enterprise Server (critical 10.0)
- [CVE-2022-23739](https://insights.sbomify.com/CVE-2022-23739/): Missing authorization in GitHub Enterprise Server (critical 9.8)
- [CVE-2022-46255](https://insights.sbomify.com/CVE-2022-46255/): Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE (critical 9.8)
- [CVE-2021-22869](https://insights.sbomify.com/CVE-2021-22869/): Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group (critical 9.8)
- [CVE-2024-9487](https://insights.sbomify.com/CVE-2024-9487/): Auth bypass in Enterprise Server (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8606 and fix it if it is affected.

What it is: CVE-2026-8606 is a high-severity server-side request forgery vulnerability in Github Enterprise Server, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-8606 in the wild and no public exploit code.

Affected product: Github Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8606/ (Markdown: https://insights.sbomify.com/CVE-2026-8606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8606
- OSV: https://osv.dev/vulnerability/CVE-2026-8606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8606/
Summaries are generated and may contain mistakes; the official description above is the record.
