# CVE-2026-86062: LightRAG: Stored Cross-Site Scripting (XSS) in the LightRAG WebUI chat/answer renderer via ingested content

> Attackers can inject malicious scripts via ingested documents in LightRAG WebUI, allowing execution of JavaScript and theft of API tokens from victims.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-xpjq-3w4w-w5wr, PYSEC-2026-4065

## What is CVE-2026-86062?

CVE-2026-86062 is a medium-severity cross-site scripting vulnerability in HKUDS LightRAG, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.5.5, lightrag_webui/src/components/retrieval/ChatMessage.tsx renders answer and thinking content with react-markdown, rehypeRaw, and skipHtml=false without an HTML sanitizer. An attacker who can add a document can store raw HTML that is returned through the query path and rendered as active content by MessageMarkdown. A user who later retrieves the content can execute attacker-controlled JavaScript through elements such as an iframe srcdoc; the additional Mermaid securityLevel: loose rendering path also injects generated SVG through innerHTML. The script runs in the LightRAG WebUI origin and can read the API token in localStorage and perform API actions as the victim. This issue is fixed in version 1.5.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-86062?

3 open source packages ship an affected version, including lightrag-hku.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lightrag-hku` | PyPI | All versions | 1.5.5 |
| `lightrag-hku` | PyPI | All versions | 1.5.5 |
| `lightrag-hku` | PyPI | All versions | 1.5.5 |

## How do I fix CVE-2026-86062?

Upgrade lightrag-hku to 1.5.5 or later.

## Is CVE-2026-86062 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86062 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86062 and fix it if it is affected.

What it is: CVE-2026-86062 is a medium-severity cross-site scripting vulnerability in HKUDS LightRAG, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86062 exists.

Affected packages and fixed versions:
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86062/ (Markdown: https://insights.sbomify.com/CVE-2026-86062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86062
- OSV: https://osv.dev/vulnerability/CVE-2026-86062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86062/
Summaries are generated and may contain mistakes; the official description above is the record.
