# CVE-2026-86063: Claude Code: Plugin Hash Pin Bypass Allows Bypass of Hash Pinning

> Attackers can bypass hash pinning in Claude Code by creating branches named after commit SHAs, leading to installation of malicious plugin code.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-pq7j-f95f-qfcv, MINI-r3r8-hmgf-fmm4

## What is CVE-2026-86063?

CVE-2026-86063 is a high-severity vulnerability in anthropics claude-code, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Claude Code is an agentic coding tool. Prior to 2.1.179, the Claude Code and Claude Desktop plugin installation flow runs git checkout for a marketplace-pinned commit without verifying that the resulting HEAD equals the pinned 40-character SHA. An attacker who controls a plugin repository on a Git host that permits SHA-shaped branch names can create a branch named after the reviewed commit, causing checkout to select the branch tip and install attacker-controlled plugin code. Exploitation requires a user to install the malicious plugin and pin it to the ostensibly safe hash. This issue is fixed in version 2.1.179.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2026-86063?

2 open source packages ship an affected version, including @anthropic-ai/claude-code.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.179 |
| `@anthropic-ai/claude-code` | npm | All versions | 2.1.179 |

## How do I fix CVE-2026-86063?

Upgrade @anthropic-ai/claude-code to 2.1.179 or later.

## Is CVE-2026-86063 being exploited?

There is no known exploitation of CVE-2026-86063 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86063 and fix it if it is affected.

What it is: CVE-2026-86063 is a high-severity vulnerability in anthropics claude-code, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-86063 in the wild and no public exploit code.

Affected packages and fixed versions:
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.179
- @anthropic-ai/claude-code (npm): affected all versions; fixed in 2.1.179

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86063/ (Markdown: https://insights.sbomify.com/CVE-2026-86063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86063
- OSV: https://osv.dev/vulnerability/CVE-2026-86063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86063/
Summaries are generated and may contain mistakes; the official description above is the record.
