CVE-2026-86079 n8n: Path Injection in Elasticsearch and ElasticSecurity Nodes via Unencoded Identifiers
Attackers can manipulate Elasticsearch index identifiers to access unauthorized data or administrative endpoints via path traversal in n8n nodes.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-86079?
CVE-2026-86079 is a medium-severity path traversal vulnerability in N8n N8n, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.76, 2.37.7, and 2.38.2, the Elasticsearch and ElasticSecurity nodes interpolated workflow-controlled index and document identifiers directly into REST request paths. An identifier containing path separators or dot segments could select another index or a cluster administration endpoint under the stored Elasticsearch credential. The affected request construction includes packages/nodes-base/nodes/Elastic/Elasticsearch/GenericFunctions.ts and the missing toPathSegment encoding. This issue is fixed in versions 1.123.76, 2.37.7 and 2.38.2.
Weakness: CWE-22
Which versions are affected by CVE-2026-86079?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.76 |
n8n npm | All versions | 1.123.76 |
n8n npm | From 2.0.0 | 2.37.7 |
n8n npm | From 2.0.0 | 2.37.7 |
n8n npm | From 2.38.0 | 2.38.2 |
n8n npm | From 2.38.0 | 2.38.2 |
Products include N8n N8n.
How do I fix CVE-2026-86079?
Upgrade n8n to a fixed version for your release line: 1.123.76, 2.37.7 or 2.38.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-86079 being exploited?
There is no known exploitation of CVE-2026-86079 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-f2cp-m7mv-8jpv, MINI-44m2-q5c6-hf6m.