CVE-2026-86082 n8n: Domain-Restriction Bypass via Unguarded Model-Search Endpoint in OpenAI Chat Model Node
Attackers can bypass domain restrictions in the OpenAI Chat Model node to send credentials to arbitrary hosts via the model-search endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-86082?
CVE-2026-86082 is a high-severity server-side request forgery vulnerability in N8n N8n, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.76, 2.37.7, and 2.38.2, the OpenAI Chat Model node enforced credential allowed-domain restrictions for normal calls but not for the model-search dropdown. A workflow editor could set options.baseURL to an arbitrary host and make the searchModels path send the openAiApi credential there. The affected implementation is packages/@n8n/nodes-langchain/nodes/llms/LMChatOpenAi/methods/loadModels.ts, which omitted assertOpenAiCredentialAllowsUrl. This issue is fixed in versions 1.123.76, 2.37.7 and 2.38.2.
Weakness: CWE-918
Which versions are affected by CVE-2026-86082?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.76 |
n8n npm | All versions | 1.123.76 |
n8n npm | From 2.0.0 | 2.37.7 |
n8n npm | From 2.0.0 | 2.37.7 |
n8n npm | From 2.38.0 | 2.38.2 |
n8n npm | From 2.38.0 | 2.38.2 |
Products include N8n N8n.
How do I fix CVE-2026-86082?
Upgrade n8n to a fixed version for your release line: 1.123.76, 2.37.7 or 2.38.2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-86082 being exploited?
There is no known exploitation of CVE-2026-86082 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-34ff-336r-5q23, MINI-2328-p6xq-vmvp, ROOT-APP-NPM-CVE-2026-86082.